• DR-IT Software
  • Products
  • Documentation
  • Product page
  • Examples
  • API reference
  • Support
Show / Hide Table of Contents

Namespace DRIT.Mail.Rfc.Shared

Classes

Base64

Provides Base64 encoding and decoding (RFC 2045 §6.8). The decode method is tolerant of embedded whitespace (CRLF, spaces) as permitted in MIME bodies.

LineReader

Reads lines from a stream, handling CRLF, LF, and CR line endings, and optional line unfolding (continuation lines) per RFC 5322 (MIME) or RFC 5545/6350 (iCal/vCard).

ParameterParser

Parses parameter sections (e.g. ;PARAM=VALUE;PARAM="quoted") used by both iCalendar (RFC 5545 §3.2) and vCard (RFC 6350 §3.4) property lines.

QuotedPrintable

Provides Quoted-Printable encoding and decoding per RFC 2045 §6.7.

RfcParameter

A single name-value parameter parsed from a property parameter section.

TextEscape

Provides text escaping and unescaping for iCalendar (RFC 5545 §3.3.11) and vCard (RFC 6350 §3.4) text values. The escaped characters are: backslash, comma, semicolon, and newline.

Enums

LineFoldingMode

Specifies how line folding (unfolding) is handled by LineReader.

Back to top

DR-IT Software documentation

DR-IT Software · Products · Documentation index · Product page · Downloads · Support · Licensing

Generated by DocFX