• DR-IT Software
  • Products
  • Documentation
  • Product page
  • Examples
  • API reference
  • Support
Show / Hide Table of Contents

Namespace DRIT.Mail.Rfc.Mime.Encodings

Classes

Base64Decoder

Decodes Base64-encoded content, tolerating embedded whitespace (RFC 2045 §6.8).

Base64Encoder

Encodes binary data to Base64 with MIME line wrapping (76 characters per line).

EncodedWordDecoder

Decodes RFC 2047 encoded words (=?charset?encoding?encoded_text?=) from header field values.

EncodedWordEncoder

Encodes header text containing non-ASCII characters as RFC 2047 encoded words (=?utf-8?B?...?= or =?utf-8?Q?...?=).

ParameterDecoder

Decodes RFC 2231 parameter continuations and charset-encoded parameter values from MIME header parameters (e.g. filename*=utf-8''... or filename0=...; filename1=...).

QuotedPrintableDecoder

Decodes Quoted-Printable content (RFC 2045 §6.7).

QuotedPrintableEncoder

Encodes binary data to Quoted-Printable (RFC 2045 §6.7).

Back to top

DR-IT Software documentation

DR-IT Software · Products · Documentation index · Product page · Downloads · Support · Licensing

Generated by DocFX